Importing files to Fusion360

Hey folks,

I’ve been having some issues importing Wikihouse files into Fusion360 and have spent the better part of the last three days troubleshooting. I figured I’d share my process in case anyone else has the same problem!

I tried several different file types, but importing the .3dm files directly seems to be the best way to preserve the naming of blocks/components. However, I found some glitches that prevented the geometry from properly importing that needed to be fixed manually in Rhino prior to uploading into Fusion360.

Here’s what I did:
-Open the .3dm file in Rhino
-Delete anything that isn’t a block (text, curves, etc.)
-Delete any double-nested blocks (BlockEdit > Select nested block that has double-nested block(s) > Explode > BooleanUnion)
-Check for non-manifold edges (Copy > ExplodeBlock > SelNonManifold)
-Check for open polysurfaces (Copy > ExplodeBlock > SelOpenPolysrf)
-Fix the non-manifold blocks and open polysurfaces (BlockEdit > Select nested block from list > Explode > Ctrl A > Join > BooleanUnion) - if this doesn’t work you have to edit it manually
-Check to make sure each block definition has only one polysurface in it (I wrote a Grasshopper script to do this automatically)
-Purge unused block definitions
-Save as .3dm file

That got me 90% there, but Fusion360 doesn’t seem to like Rhino blocks that have been mirrored from their original definition… these components have a funny display issue where the component is supposed to look solid but it appears transparent. This might be a non-issue unless we want to make nice renderings, so I wanted to find a solution.

I tried importing it as a .step file but then the mirrored blocks lose their component naming.

I could manually explode and redefine the blocks in Rhino but that would take… forever.

The only viable workaround I’ve found is to upload the .3dm into Fusion360, then export from Fusion360 to .step, then re-upload the .step file. This fixes the display issue and preserves component naming BUT for some reason, it makes component instances unique instead of preserving editing capabilities across multiple instances (edit one and it changes all other instances) - this is fine just something to be aware of.

EDIT: If I open the .3dm in Fusion360, export it as a .step file, open the .step in Rhino, save it as a .3dm again, then open the new .3dm in Fusion360, component instances are preserved. What a strange glitch!

Has anyone else had the same issue, and found an easier solution? Thanks!

1 Like

I have also imported the Skylark libraries and had no real problems to import them from DWG into Fusion 360. I am happily assembling houses with them.

Hmm that’s interesting to hear! I tried .dwg but had similar results to the .3dm files.

The only bug in the 250 .dwg library is that these boards are moved 18mm to the left.

It is a little bug to report back to WikiHouse.
But easy to correct

@wilsonem If you want I can upload the 180mb Fusion Library file for you in f3d format.
It is too big to upload to Github easy. So I can send it with WeTransfer if you give me your email address.

@Mel If you can add it to Githup, it can be also available to others.


Thanks @melhof! I managed to get the few blocks I needed by editing them manually, but if I ever need the full library I will let you know :slight_smile: